
P S P I C E  T U T O R I A L  
P A R T  I :  I N T R O D U C T I O N  A N D  D C  A N A L Y S I S  

f o r  t h e  

O r c a d  P S p i c e  R e l e a s e  9 . 2  L i t e  E d i t i o n  

 
 
 
 

INTRODUCTION 

The Simulation Program with Integrated Circuit Emphasis (SPICE) circuit simulation tool was first 
developed in the early 1970s.  It was written in the FORTRAN programming language and was 
intended to support the early data entry methods of this period.  SPICE was immediately valuable to 
allow circuit designers to analyze circuit systems, in particular as the complexity of circuits began to 
expand with the arrival of the first integrated circuits.  It is certainly one of the most important tools 
in Electrical Engineering and is an example of one of the first tools for Computer Aided Design. 
 
SPICE has evolved with many advances in numerical analysis methods for accurate and fast 
computation and has appeared in many commercial forms.  SPICE has been ported to many 
platforms and the version that operates over the Windows operating system is PSpice. 
 
The first SPICE users designed circuits with manual circuit drawing tools.   Then, inspection of the 
circuit design was used to generate a text-based description of the circuit design.  Even today this still 
occurs in certain special instances.  However, the arrival of graphical drawing tools allows a circuit 
designer to directly draw circuit schematics using circuit design tools and then special “capture” tools 
operate to “capture” the schematic and generate the text-based description of the circuit design, 
automatically.  The versions of PSpice available to us operate in this way. 
 
This is a great advantage for the engineering design process – this provides the designer with the 
ability to focus directly on a visual description of their system and obtain circuit operation numerical 
and graphical results in an automatic, convenient process. 
 
This Tutorial describes the development of two typical, simple circuits.  The first is a circuit that will 
demonstrate the ability to quickly compute voltage and current values. The second will demonstrate 
the ability to compute time-dependent circuit response. 
 



 

ACCESS TO PSPICE 

The SEASnet laboratory PCs all carry an installation of PSpice 9.2 Lite. If you wish to install this 
version of PSpice on your personal machine, you may order a free PSpice 9.2 Lite CD from Cadence 
at  
 
http://www.orcad.com/Partner/Solution/ContentPage/cddemo4.asp 
 
You may also download the PSpice 9.1 version from  
 
http://www.orcad.com/Product/Simulation/PSpice/download.asp 
 
 
 

INSTALLATION 

 
You may use the SEASnet PCs for your work.  However, if you decide to install Orcad Family 
Release 9.2 Lite Edition software, then in the installation process you will be presented with options 
as to which components to install.  Ensure that you have selected to install Capture and PSpice.  You 
may install other options in addition to these. 
 
 



 
 

CIRCUIT I :  DC ANALYSIS 

 
 
Now, we will first use PSpice to simulate the circuit of Figure 2.16 in Electric Circuits in Nilsson and 
Riedel, shown below.  
 

 

 
 
 
 

GETTING STARTED 

 
After installation, your Program folder should contain the PSpice software.  So, select Start > 
Programs > Orcad Family Release 9.2 Lite Edition > Capture Lite Edition.  This will launch 
the Capture application. 
 
Your screen should appear as in Figure 1. 
 



 
Figure 1 

 
Now, to begin, you must create a new Project.  We will be engaged in Analog Design in this EE10 
course.  So, your new Project selection will be for a new Analog Design project. 
 
Begin by selecting the File > New > Project menu.  Your screen should appear as in Figure 2. 
 

 
Figure 2 

This will launch the Project dialog.  At this point, you must create a directory for your new projects.  
Here we have created a directory of D:\My Documents\PSPICE\Projects in Figure 3. 
 



 
Figure 3 

You should now configure the application so that an Analog or Mixed A/D (analog or mixed analog 
and digital design) is selected.  Also, you should entire a Project Name.  This has been selected to be, 
Figure 2.16 Circuit Simulation.  Please note carefully that the Analog or Mixed A/D checkbox has 
been highlighted. 
 
Now, upon confirming your selection by clicking on the OK button, another choice will appear.  
This prompts you as to whether you would like to create a new Project based on a previous Project.  
For this case, select Create a blank project, as shown in Figure 4 and then press the OK button. 
 

 
Figure 4 

 



 
 
Now, this will bring up the Capture schematic graphics window, as in Figure 5.  This will now allow 
you to actually draw a circuit with electronic components that can be individually adjusted for their 
properties.  We are ready to begin designing. 
 

 
Figure 5 

 
A very important point should be considered first:  The PSpice system computes voltage values 
relative to a common potential (referred to as a “Ground” potential).  Without a specification for this 
Ground potential, the circuit simulation may not proceed (the circuit simulation algorithm does not 
make assumptions as to what reference potential the designer has selected, instead, it must be 
informed in advance).  In fact, the error condition resulting from a lack of Ground potential 
definition creates so-called “floating” nodes, simply circuit nodes that do not have a defined 
potential. 
 
As you will see throughout engineering circuit design, the clear definition of reference potentials 
continue to be a challenge for all technologies in analog, digital, radio frequency design, and 
biomedical electronics.  Many problems in system design have their origins in the difficult of 
establishing a common reference for measurement. 
 
So, we will start by selecting a “Ground” potential point 
 
First, the Ground potential reference point is a circuit node or in the Place menu.  We want to 
“Place” this node in our circuit.  So, you may reach this by pointing to the Place menu, as in Figure 6. 
 
 



 
Figure 6 

Now, click on Ground, and you will see the Ground dialog box as in Figure 7. 
 

 
Figure 7 

You should see the Libraries highlighted as shown.  Now, select the 0/Source selection as in Figure 
8. 

 
Figure 8 

 



Then, click on OK and you will now find that there is a Ground symbol attached to your mouse 
cursor as in Figure 9. 
 

 
Figure 9 

Place this as shown in Figure 10 by clicking with the left mouse button.  Then, click with the right 
mouse button.  If you are not careful here, you will accidentally create two ground terminals (one will 
have to be deleted by right clicking on the part and deleting it). 
 

 
Figure 10 

To view the circuit more easily, click on View > Zoom > In. 
 
Now, we will add a conductor (Wire) to our circuit.  Again, proceed to the Place menu, select Wire, 
and this will now create a drawing tool.  You may create the wire by placing the mouse cursor on the 



terminal at the top of the Ground symbol and then holding down the left mouse button while 
dragging the mouse cursor upwards (as you can see this is the standard Windows drawing paradigm 
so this will be familiar to you.)  The circuit will now appear as in Figure 11. 
 

 
Figure 11 

Now, we must start to add Resistor and Source components.  To obtain and “Place” these parts we 
again navigate to the Place menu.  But, this time, click on Part.  This will bring up a Place Part dialog 
box. 
 
At this stage, we need to add Parts Libraries to our list of choices. You will need to perform this only 
once, in the future, the Libraries will appear by default.  So, click on Add Libraries and you should 
see the choices of Figure 8. 
 

 
Figure 12 

 



 
Figure 13 

 
We need to add the following Libraries: 
 

1) analog.olb 

2) eval.olb 

3) source.olb 

4) sourcstm.olb 

5) special.olb 

 
Now, we can add a Resistor to our circuit.  Click on Place > Part and then when the Place Part 
dialog box appears, highlight the ANALOG library in the Libraries box. This will bring up a list of 
parts in the Part List box.  Now, scroll down to R and click on this.  You should see the dialog box 
of Figure 14. 
 

When we enter device property values into PSpice configuration settings or directly into 
SPICE code, we generally use a scientific notation for number entry that includes a scale 
factor equal to a power of 10.  The Appendix at the end of this document describes the 
SPICE and PSpice Units of Measure as well as the scale factor conventions.  It is important to 
read this very carefully.  Frequent errors in SPICE and PSpice simulation result from a confusion over entry 
of a proper scale factor. 

 



 
Figure 14 

 
Click the OK button to select this and then you are ready to Place this part.  Proceed to place this 
part as shown in Figure 15. 
 

 
Figure 15 

 
Its default value is 1 kilo-Ohm.  We now want to change its value to 5 Ohms.  So, double-click on 
the Part.  This will bring up the Property Editor, as shown in Figure 16. 



 
Figure 16 

 
Now, scroll horizontally to the “Value” property box at the far right.  You may highlight the contents 
of this box and then enter “5” to set the Resistor value at 5 Ohms. 
 
Now, it is important to click on Apply at this stage to set the value.  Now, return to the Schematic 
window via the Window Menu as in Figure 17. 
 
 

 
Figure 17 

 



 
Figure 18 

 
At this stage we will add a Current Source.  This will be a direct current (DC) source and will be 
labeled as IDC by PSpice.  So, proceed to the Place > Part menu to bring up the Place Part dialog.  
Highlight the SOURCE Library and then IDC as in Figure 19. 
 
 

 
Figure 19 

 
Now, upon clicking OK, we are ready to place this source.  Place the Current Source so that its 
terminal connects to the junction of the Resistor (R1) and Ground Wire.  Then, right click to bring 
up a configuration menu as in Figure 20. 
 



 
Figure 20 

 
Now, select Rotate.  You will then be able to drag the Current Source into the position shown in 
Figure 21.  Now, use the Property Editor to set its current to 1 Ampere by updating the DC column 
as shown in Figure 21.  (Remember to press the Apply button). 
 

 
 

Figure 21 

 
 



 
Figure 22 

Now, you are ready to add additional components.  All of the current sources will be set to 1 
Ampere. 
 
Here is the appearance, in Figure 23, of the circuit when additional wires, a Current Source and the 4 
Ohm Resistor have been added.  Note that you may click on the Part labels directly and change their 
values and names.  Also, the labels may be moved to make a schematic more legible. 
 

 

Figure 23 

 

 



After additional components, we have the Schematic of Figure 24.  This is a very important stage to 
highlight a critical feature. 
 
Note that in the circuit of Figure 2.16 of Nilsson and Riedel, there is no connection between the 
conductors connecting nodes a and c and conductor connecting node d with the Current Source 
terminal, as shown in Figure 24, below. 
 
We must be very careful to recognize this and to design the schematic of Figure 25 properly.  Note 
the position of the node junctions appearing as red “dots” in Figure 25 and note that no junction 
appears in the center of the schematic diagram where the two conductors cross (the conductors are 
those connecting R2 and R3 and the conductor connecting Ground and I4).   

 
Figure 24 

 

 
Figure 25 

 



Now, we complete the circuit as shown in Figure 26. 
 

 
Figure 26 

 
Now, with our circuit complete, we are ready to start a Simulation.  First, we must configure the 
Simulation tool.  Proceed to the PSpice menu and click on New Simulation Profile as in Figure 27. 
 

 
Figure 27 

 
We have entered the name “Bias” into the Name field and have left the Inherit From entry equal to 
noon.   
As we will have discussed in lecture, the term “bias” refers to the notion of a tendency or asymmetry.  
Bias is a voltage generated across a device or combination of devices.  It may be created directly by a 
voltage source, or indirectly through a combination of sources and other components. 
 
Bias analysis refers to the operation of determining this arrangement of voltages.  In general, bias 
analysis is critical.  Later, as we encounter nonlinear circuit elements, you will see that bias analysis 
and design for a stable, predictable set of bias voltages is often one of the most important concerns. 
 
So, we now click on Create.  This will bring up the Simulation Settings-Bias dialog box as in Figure 
28. 
 



 
Figure 28 

 
Now, the Analysis type we must select is Bias Point.  You can reach this by scrolling through the 
Analysis type selections and clicking on Bias Point.  We do not need to select any of the Output 
File Options, so simply click on OK.   
 
Now, start the Simulation by clicking on PSpice > Run.  The output will appear as in Figure 29. 
 

 
Figure 29 

 
Note that now the circuit potentials at each node are computed.  Also, we can determine the currents 
through each element.  To obtain this information, we can examine the Simulation Output File.  
Navigate to PSpice > View Output File. 
 



The Output File contains a PSpice program listing that was generated by “capturing” the schematic.  
This program listing was the target analyzed by PSpice to determine the Bias the list of bias voltages 
for each element, as shown in Figure 30. 
 

 
Figure 30 

Also, we may examine the Bias analysis for current values.  Generally, the display default will be to 
show Bias Voltages.   To observe Currents, click on I and de-select V in the Toolbar.  The Bias 
Current display will appear as in Figure 31.   

 
Figure 31 

 



Finally, also select W to display power dissipation for each device, as in Figure 32.  Note that power 
is being extracted from the Sources (they are delivering power) and show negative power dissipation 
values. While the Resistors, which are absorbing power and have power being delivered to them, 
show positive power dissipation values. 

 

 
Figure 32 

You may modify this circuit, for example by increasing the I3 current to 2A.  In this event, you must 
execute PSpice > Run again in order to view valid results.  This has been done to generate Figure 
33. 
 

 
Figure 33 

You may Save your work with the File > Save command.  When you close your Project, you will be 
prompted by a pop-up dialog box to Save your Project files.  You should select Save All. 



 

APPENDIX:   

UNITS OF MEASURE FOR SPICE 

 
Before we proceed, however, we will discuss the units of measure that SPICE expects and will 
interpret from our input. 
 
As you will see, device property values in SPICE components are entered as an integer or real 
number, followed by a case-insensitive scale factor.  For example, 1,000 Ohms may be entered as 
1000, 1k, or 1K, where K is a scale factor equal to 103.  For another example, 1,263,345 Ohms may 
be entered as 1.263345 meg, 1.263345 MEG, or 1263.345K, where MEG is a scale factor equal to 
106. 
 
If no scale factor is supplied then SPICE interprets the scale factor to be unity.  Thus, if we enter 5 
for a Resistor value, this will be interpreted as 5 Ohms. 
 
The units for calculation and measurement are: 
 

1. Resistor:  Ohm 
2. Capacitor: Farad 
3. Inductor: Henry 
4. Potential: Volt 
5. Current: Ampere 

 
The scale factors are: 
 
 

Scale Factor Term Numerical Factor Upper Case SPICE 
Factor 

Lower Case Spice Factor 

Tera 1012 T t 
Giga 109 G g 
Mega 106 MEG meg 
Kilo 103 K k 
Unity _ _ _ 
Milli 10-3 M m 

Micro 10-6 U u 
Nano 10-9 N n 
Pico 10-12 P p 

Femto 10-15 F f 

 
 



Now, it is important to note that confusion can easily lead to very large errors.  For example, it may 
be tempting to write 1 Farad as 1 F.  However, this is interpreted as 1 femtoFarad and an error of 15 
orders-of-magnitude will result! 
 
Also, it is common error to use “M” or “m” to denote 1 Million, by accident.  However, this is 
interpreted as a scale factor of Milli or 10-3, an error of 9 orders-of-magnitude.  
 
It is essential to carefully review and follow the scale factor rules. They will become familiar soon. 
 
 


